moto guzzi problems …

I’ve had my Moto Guzzi V7 Cafe Classic from new, which I think was in 2012 and it’s been a really good bike.

In the time I  have had it, I have never had any significant faults or issues, although in the early days I had some issues with the stock indicators.

Although they looked decent enough and looked like they were chrome, they were actually made of an altogether too brittle plastic – the upshot being they cracked with the stresses and strains of the bumps of the road and I guess the general vibration from the V- twin.

As far as I can recall the first time I replaced the rear indicators with OEM parts I had the same thing happen again, and then later the same issues with the front indicators.  Over the years they have all been replaced with metal stemmed indicators that for the most part have been pretty satisfactory.

A couple of weeks ago I was out on the bike and after stopping at one of my regular coffee haunts, the bike wouldn’t start. On this occasion there was someone there (a biker who was in  his car) and who was able to give me a push. Thankfully the engine came to life on the first attempt and I was able to ride home.

Once home and when I got round to having a look, the best guess I could make was maybe the battery connections were loose, I double checked, tightened and set the battery on it’s optimiser. The following day the battery was showing full charge and good health, over the next couple of weeks I started the bike most days and it started and ran on each occasion without any trouble at all.

Next time out after stopping to take a few pictures the fault replicated itself again and I was left with the devil of a job to bump start it. Sheer chance and good fortune had me on a quiet back road and only 50 yards or so away from an incline.

It wasn’t the easiest of times and took me half a dozen attempts before the engine fired. As with the previous occasion one the bike was running I was able to ride home without any further problems but it very much spoiled what should have been a decent ride on a decent day.

My instincts tells me it’s the battery that needs replacing but before I do that I have arranged to drop it into my local workshop next week for the guys there to have a look. Logic tells me it can only be one of a limited number of faults, but I know they are much better placed than me to identify the issue.

I’ll post an update here in due course.

Some pictures below from my shortened ride are in the gallery below the link to recent posts.

Links to recent posts are set out below. Scroll down for the picture gallery for this post:

And it’s another Scotland trip;

On the road to Scotland Again;

More time on the F800R

Luggage on the F800R

Different Day/Different Bike

Out & about on the F800

First ride on the F800

New Bike Day;

Worth a stop;

On the Road;

Cumbria and the Dales;

Or check out the Lockdown Lookback – The Motorbike Years series